ピアのパソコン学習ガイド
メニュー
Excelの操作

パワークエリ(Power Query)の使い方|CSVの取り込み・複数ファイルの結合

ピアのパソコン学習ガイド 編集部2026年11月7日 更新

※写真はイメージです

一言でいうと

パワークエリ(Power Query)は、毎月同じようにやっている「データの取り込み・整形」を記録して、次からはボタン1つ(すべて更新)でやり直してくれる機能です。CSVの読み込み、いらない列の削除、空白行の削除、複数ファイルの結合などを、関数もマクロも使わずにできます。「データ」タブの「データの取得」から始めます。

「データ」タブの「データの取得と変換」 ファイル ホーム 挿入 ページレイアウト 数式 データ 校閲 表示 データの取得 テキストまたはCSVから テーブルまたは範囲から すべて更新
「データ」タブの左側、「データの取得と変換」のグループがパワークエリの入口です。

パワークエリでできること

よくある作業パワークエリなら
毎月、基幹システムのCSVを開いて、いらない列を消して、日付を直す1回手順を作れば、翌月は「すべて更新」だけ
支店ごとのファイル(12か月分)を1つの表にまとめるフォルダーを指定すると全部くっつけてくれる
空白行・重複・余分なスペースを消すボタンで消せて、その手順も残る
2つの表を、商品コードでくっつける「クエリのマージ」でVLOOKUPなしでできる

基本の使い方(CSVを読み込んで整える)

  1. 「データ」→「テキストまたはCSVから」でファイルを選ぶプレビューが出ます。
  2. 「データの変換」を押すパワークエリエディターが開きます。
  3. いらない列を選んで右クリック →「削除」右の「適用したステップ」に手順が1つずつ記録されていきます。
  4. 空白行を消す・型を直す「行の削除」→「空白行の削除」、日付の列の見出しの左のアイコンで「日付」を選ぶ、など。
  5. 「閉じて読み込む」整った表がシートに出ます。
  6. 翌月は「データ」→「すべて更新」元のCSVを同じ場所・同じ名前で上書きしておけば、同じ手順で作り直されます。

複数のファイルを1つにまとめる

  1. まとめたいファイル(同じ形の表)を1つのフォルダーに入れる
  2. 「データ」→「データの取得」→「ファイルから」→「フォルダーから」
  3. 「結合」→「データの結合と変換」1つ目のファイルを見本に、全部のファイルが縦につながります。ファイル名の列も付くので、どの支店のデータかも分かります。

あとでファイルを足しても、フォルダーに入れて「すべて更新」を押せば、まとめた表に追加されます。

使えるExcel

Windows版のExcel 2016以降・Microsoft 365で使えます。Mac版のMicrosoft 365でも使えますが、使える機能が少なめです。Web版では、作ったクエリの更新はできますが、エディターで手順を作れる範囲は限られます。

うまくいかないとき

1「すべて更新」で「ファイルが見つかりません」と出る

元のファイルの場所か名前が変わりました。

直し方クエリを右クリック →「編集」→ 右の「ソース」の歯車で、ファイルの場所を選び直します。

2日付や数字が文字のまま

列のデータ型が「テキスト」のままです。

直し方エディターで列の見出しの左のアイコンを押し、「日付」や「整数」を選びます。

よくある質問

パワークエリとは何ですか?

データの取り込みと整形の手順を記録して、次からは「すべて更新」だけで同じ作業をやり直してくれるExcelの機能です。

パワークエリとマクロのちがいは?

マクロは何でも自動にできる代わりにVBAが要ります。パワークエリはデータの取り込み・整形に絞られていて、マウスの操作だけで作れます。

パワークエリはどこにありますか?

「データ」タブの「データの取得と変換」のグループです。

一緒に覚えたい関数・操作

このページについて

操作の説明は Microsoft 365 の日本語版Excel(Windows)に合わせています。図はこのサイトで作ったもので、表の会社名・商品名・人名は架空です。運営者情報